
Architectural Engineering Senior Thesis 
CPEP Webpage Guidelines and Instructions 

 
 

Your Thesis Drive (T:\) 
  Each student is allocated space on the Thesis drive.  Any files on this drive are accessible from the 
web.  As the server has limited space, please be sure to use this drive only for thesis files.  Also, please be 
sure to clean out old or unused documents at the end of the year. 
 
  Your T:\ drive should already be mapped on the AE lab computers.  If it is not, you can map it 
with the following: \\aeweb.coeaccess.psu.edu\xyz123$ 
 
  You may also map your T:\ drive from home using standard procedures as described at 
http://www.engr.psu.edu/ae/labcomputing 
 
Software 
  You may create your CPEP page using any software you wish but using Dreamweaver is 
recommended.  Dreamweaver and the associated Adobe CS3 programs are installed on all AE lab 
computers.  Be aware that if you choose to use another program help may not be available should 
difficulties arise. 
 
  When you are working to create your site, you can preview your site in a browser by using thing 
F12 button or by going to File>Preview in Browser.  It is recommended that you install Firefox onto your 
computer and check your pages in both Internet Explorer and Firefox.  Not all web browsers render a 
page in the same way.  A page may look great in Internet Explorer, but have problems in Firefox.  This 
situation can get a bit tricky, but there is usually a reason for the problem that can be worked out. 
 
Creating a Site 
  The first step to setting up your website is to create a ‘site’ in Dreamweaver.  This allows you to 
easily access, edit, and manage all the content on your T:\ drive directly from Dreamweaver without 
having to use the typical Windows Explorer system. 
 
  There are several ways to get into the dialog for creating a new site.  The easiest is when you first 
open Dreamweaver.  A menu will pop up and you can select the option to create a new ‘Dreamweaver 
Site’.  The following options should be used as you go create your site: 
 

1. Name:  Whatever you wish (i.e. My CPEP) 
2. URL:  http://www.engr.psu.edu/ae/thesis/portfolios/2011/xyz123 
3. Select ‘No, I do not want to use a server technology’ 
4. Select ‘Edit directly on server using local network.’ 
5. Type ‘T:\’ for ‘Where are your files on the local network?’ 

 
Your site is now created and you are ready to begin the design process. 
 
Required Content 
What does my site have to include?  Each CPEP must contain at least four main sections; these include a 

page‐heading, navigation menus, page content, and a page‐footer.  The information that must appear in 
each of these sections can be found below.  See a page from one of last year’s students for an example.   

 
o Header 



• Your first and last name 
• Your Option 
• Your building’s name 
• Your building’s location 

 
o Navigation Menus 
• Home ....................................... A link back to your Introduction page 
• Student Biography ................... A brief page which introduces yourself 
• Building Statistics 
• Thesis Abstract 
• Technical Assignments 
• Thesis Research 
• Thesis Proposal 
• Presentation ............................ Your final PowerPoint® Presentation 
• Final Report 
• Reflection 
• Senior Thesis e‐Studio ............. A link to the main course site 

 
o Page Content: 
• Introduction  to  your  site  and what  senior  thesis  is.    Possible  layouts  (similar  to  the  template) 
include range of other features that you can incorporate into your design.  

 
o User Note: 
●  “Note: While great efforts have been taken to provide accurate and complete information on the 
pages of CPEP, please be aware  that  the  information  contained herewith  is  considered a work‐in‐
progress for this thesis project. Modifications and changes related to the original building designs and 
construction methodologies for this senior thesis project are solely the interpretation of Christopher 
Ankeny. Changes and discrepancies in no way imply that the original design contained errors or was 
flawed.  Differing  assumptions,  code  references,  requirements,  and  methodologies  have  been 
incorporated  into  this  thesis  project;  therefore,  investigation  results may  vary  from  the  original 
design.” 
 

o General Description 
●  The Capstone Project Electronic Portfolio (CPEP) is a web‐based project and information center. It 
contains material produced  for a year‐long Senior Thesis class.  Its purpose,  in addition to providing 
central  storage  of  individual  assignments,  is  to  foster  communication  and  collaboration  between 
student, faculty consultant, course instructors, and industry consultants. This website is dedicated to 
the  research  and  analysis  conducted  via  guidelines  provided  by  the  Department  of  Architectural 
Engineering. For an explanation of this capstone design course and its requirements click here. 

 
o Footer 
•  Links to: Senior Thesis Main Page, Penn State, AE, AE Computer Labs, Contact, Others as you want 
• “This page was  last updated on *DATE*, by *YOUR NAME* and  is hosted by  the AE Department 
©20XX” 

 
Again this list includes only the minimum requirements for the course, feel free to add and improve 

your site.   You may want  to view  the sites of previously successful students  to see what a good  layout 
includes.   For  those of you who are  familiar with how  to make websites you may use  this  list as your 
starting point and are encouraged to create your CPEP from scratch, but must NOT implement frames into 
your design, as this leads to the inability of searching for your site easily‐ No Frames allowed. 
 



Using a Template 
  Templates were created specifically for Thesis students in 2005 to help students new to web 
design get a good start for thesis.  Several difficulties have come up over the past two years and the use of 
these templates is no longer encouraged.  They are still available at 
http://www.engr.psu.edu/ae/thesis/assignments/templates/ if you wish to use them, but it is 
recommended that you have some previous knowledge with .CSS files if you wish to customize them. 
 
  Another option is to use a template provided by Dreamweaver.  These templates make a good 
start to your thesis webpage, but can be cumbersome to edit.  The Dreamweaver templates are accessible 
through ‘File>New’.  A Menu box will appear.   If you select ‘Page from Sample’ then ‘Starter Page 
(Theme)’, several options appear.  You want to select one of the styles with the ’‐ Home Page’ 
designation.  Choose one of the options and hit the ‘Create’ button.  The page will be created and you will 
be asked to save it to your site.  Save the file as ‘index.htm’ You will then be prompted to save some files 
that the webpage uses.  Create a new folder to keep your site organized (T:\images) and make this the 
directory where the files will be saved. 
 
  The template page is now ready to be edited to make it meet the CPEP page requirements.  The 
major alterations are as follows: 

1. Menu : 
a.  Use the ‘insert row’ command to add rows to the menu on the left side of the 

page.  You can do this by right clicking in the menu, then going to table>insert row.  
You want the table to be showing nine rows. 

b. Add or replace text for each row to make a menu as described at the beginning of 
this handout. 

c. One by one, select the text in each row and add a link using the ‘link’ field at the 
bottom of the page.  For rows that already had text, the ‘link’ field will have 
“javascript:;” in it.  Replace this with your new link.  The links should be as described 
below in recommended file structure.  ALWAYS USE RELATIVE LINKS WHEN LINKING 
PAGES OR FILES (i.e. there should be no http://www...etc. at the beginning of the 
link).  These portfolios are occasionally moved to a different location or the url will 
change.  If you use global links your page will no long function correctly. 

d. The target should be ‘_self’ meaning the link opens in the same window rather than 
opening a new one. 

 
2. User Note: 

a. Click in the area below the last row of the menu bar.  From the menu, select 
Insert>Table.  Make the table one row and one column, with the table width set to 
‘100%’. 

b. The cell padding, cell spacing, and border can be played with as you like for the best 
visual appearance. 

c. You can then click in the table and add the user note described at the beginning of 
this document.  The font and color are determined by an external file called a 
cascading style sheet (discussed later in this document).  You can however override 
the style sheet by selecting the text you want to change and changing the 
properties in the menu box at the bottom of the screen. 

 
3. Footer: 

a. To add the footer you must create a table at the bottom of the page, below the 
table that includes the rest of the content.  It can be difficult to select an area 
outside of the existing table, so it is recommended that you use a split screen code 
and design view.  In the code view, scroll all the way to the bottom and click to the 



left of the </body> tag.  You can then insert a table just as was done for the user 
note.   

 
4. Other items: 

a. You will be required to change the rest of the content of the page that is 
automatically created by the template.  This should be images of your building and 
other requirements.  Note that this part of the page will be different for every page 
you create.  It is probably best to leave this empty for the time being.  You can edit 
each page individually once they are all created (described in next section). 

 
Starting From Scratch 
 Though it may seem like more work at first, this is the most straightforward process that will 
reduce potential problems in the future.  A general process to follow is: 
 

1. Start with a new file 
2. Edit the main page properties to establish defaults 

a. background color 
b. text style and color 
c. link style and color 
d. page margins 

3. Devise a layout for your page – think of what you need and how to divide up the page using 
tables 

a. You can use a combination of “%” tables and “pixel‐width” tables, but pixel‐width 
tables tend to produce more consistent results.  The body of your page should not 
exceed 1000 pixels so horizontal scrolling isn’t needed. 

i. One possible layout, although this is in no way mandatory: 
1. Table with 4 rows, 100% (use for background colors that cover the 

whole page) 
a. In top row, insert a table with 1r 1c, that is 1000 pixels 

wide (use for header) 
b. In second row, set height to a few pixels (delete content 

in code view) and set background color to make a 
dividing bar across the whole page 

c. In third row, insert table with 1r 4c that is 1000 pixels 
wide 

i. Use c1 for menu, c2 for space, c3 for content, c4 
for space, fix width of each column 

d. In bottom row, insert table with 1r 1c that is 1000 pixels 
wide (use for footer and notes) 

4. Create a menu structure and create all links (see the ‘Recommended File Structure’ section 
below). 

a. You can use simple html links or a SPRY menu bar (see the ‘Other Dreamweaver 
Features for Customization’ section below). 

5. Insert content that will be the same on every page.  Get this right now, otherwise you will 
have to edit it on every page in the future.  These items include the header, footer, and 
notes. 

6. Title the page using the input box above the work area. 
7. Preview the page in both Internet Explorer and Firefox (File > Preview in Browser).  Make 

changes if something doesn’t look right 
8. Save the page as index.htm 
9. Change the title of the page (Don’t forget this!), then use ‘Save As…’ to create the rest of the 

files in the file structure 



10. Edit the custom content within each page 
 
Other tips: 

• Always use relative links.  This is the default if you select files using the folder icon or drag and 
drop from the site window. 

• Resize images (smaller file sizes) before inserting them into Dreamweaver.  Even though you can 
resize them in Dreamweaver, if the inserted file is large, the browser still has to load the whole 
file. 

• Set the page margins (In Page Properties) to zero to avoid a border area around your page 
• Set all table borders to 0 (a blank input box is not the same as a 0). 
• Work in pixels.  Set all column widths to a pixel value.  All column widths should add up to the 

table width. 
• If you insert a picture or table that is larger than a column for which you’ve specified a pixel 

width, it will force it to be larger and it will make things confusing.    
• Use legible fonts and consider the contrast with the background.  High contrast is much easier to 

read. 
• Do not create text as an image outside of Dreamweaver.  This text won’t be searchable or 

selectable. 
• Keep your files organized.  Keep images in an ‘Images’ folder, keep your reports in a ‘Reports’ 

folder, keep your working files in a separate folder, etc.  These folders are what create the URL 
that you see in a browser.  If you rename a folder or a file (or move the file to a different folder), 
it will break any links. 

 
Recommended File Structure 
  The basic CPEP file structure mimics the menus described in the first section of this document.  
Once you edited the template to a point where you are satisfied (any change from here on will have to be 
made to each page (i.e. eight times instead of once), you can begin to use the ‘Save As…’ command to 
save new pages.  All the pages should be saved in the root of your T:/ drive.  You should have also created 
a directory for images (T:/images), and you may wish to create one for assignments (T:/assignments) and 
another for work in progress (T:/work).  This will keep your files organized.  The folder names will show up 
in the URL if, for example, you have a .pdf file in the assignments folder and you create a link to the file. 
 
  Your root folder should contain only the pages of the website.  These should all be .htm (or .html, 
but you have to be consistent with which you choose) files.  You should use the ‘Save As…’ command 
described above to create the following blank files: 
 
  index.htm 
  bio.htm 
  buildingstatistics.htm 
  abstract.htm 
  technicalassignments.htm 
  research.htm 
  proposal.htm 
  presentation.htm 
  finalreport.htm 
  reflection.htm 
   
These files can really be named whatever you like, but it is best to always use all lowercase letters and 
avoid spaces as these things can become difficult when linking files and typing in URL’s if you are 
browsing. 
 



CSS (Cascading Style Sheets) 
Both the Dreamweaver and old Thesis templates, as well as SPRY content, use what is called 

cascading style sheets to control the visual attributes of the page.  This includes items such as background 
colors, link colors, text colors, header sizes, text size, etc.  These files are used so that with one change to 
the .css file, you can change the font color or size or any other attribute for any page that references that 
given .css file.  You can, however, always override the .css file by specifying something other than the 
default values in the properties box. 
 

If you wish to change the colors for your page, you can do so by editing the .css file that was 
created with the template and saved to your directory (It’s in T:\images\ if you were following this 
document).  You can use Dreamweaver to edit the .css file, but it must be done in a code view only.  This 
is a more advanced editing feature and requires a general understanding of html code.   If you have no 
experience with web design, it is best if you have someone explain .css files in greater detail before 
attempting to alter them. 
 
Other Dreamweaver Features for Customization 
  It is possible to work with Dreamweaver or the associated Adobe CS3 programs to create almost 
anything you can imagine.  You can use Adobe Fireworks, or Adobe Photoshop to create graphics for your 
website.   

Dreamweaver CS3 also has the ability to quickly insert dynamic menu items.  These can be found 
in the ‘Insert>Layout Objects’ menu.  They are the items that start with ‘SPRY.’  These can be used to 
create a more complex menu, but will require the use of .css to edit the properties.  The help link in the 
properties box is very useful for directing you to exactly what you need to edit. 

 
In general, if you have no prior working knowledge of Dreamweaver or web design, you should 

keep your page simple.  This is not a web design course and it is possible to get in over your head using 
Dreamweaver.  It is recommended that you keep backup copies of your .htm files in case you screw them 
up beyond repair.  In the past, students have had to spend lots of time redoing pages because they were 
beyond repair.   
 
Where to Find Information and Help 
  Besides the help files and tutorials already in Dreamweaver (you can probably get anything you 
need directly from the program or its associated online help site), there is all kinds of information 
available on the web from independent parties.  Search the web for help or for tutorials on how to do 
something if you want to go beyond the standard pages that are created with the Dreamweaver 
templates. 
 


